当前浏览器不支持 SVG

发生这个错误的原因是因为你没有引入 oldie.js 这个功能模块。

从 Highcharts 6.0.0 开始,我们将兼容低版本 IE 的代码单独抽取出来并独立成一个功能模块 oldie.js,如果你的图表需要兼容到 IE6,7,8,请在 highcharts.js 之后引入这个文件。

一个非常好的方法是将代码放置在针对 IE 有效的注释中

<!--[if lt IE 9]>
    <script src="https://img.hcharts.cn/highcharts/modules/oldie.js"></script>
<![endif]-->